Matchmaking page aren't available
Resolved
Partial outage
Lasted for 23m

All issues resolved, you can go back to playing!

Wed, Apr 17, 2024, 12:08 PM
1 month ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, Apr 17, 2024, 12:08 PM
23m earlier...

Identified

We have identified the issues and are working on a fix.

Wed, Apr 17, 2024, 11:45 AM