EU Matchmaking is currently experiencing issues and may be intermittently unavailable.
Resolved
Lasted for 1h

All issues resolved, you can go back to playing!

Mon, Apr 8, 2024, 09:03 PM
1 month ago
Affected components

No components marked as affected

Updates

Resolved

All issues resolved, you can go back to playing!

Mon, Apr 8, 2024, 09:03 PM
1h earlier...

Investigating

We are aware of issues with the platform.

Mon, Apr 8, 2024, 07:04 PM