Desktop Client Login issues
Resolved
Degraded performance
Lasted for 2h

Desktop client login should be back to normal

Sat, Apr 6, 2024, 08:58 PM
1 month ago
Affected components
Play
Login
Updates

Resolved

Desktop client login should be back to normal

Sat, Apr 6, 2024, 08:58 PM
1h earlier...

Investigating

Sat, Apr 6, 2024, 06:58 PM

Investigating

We are aware of the issue with users not being able to log onto the FACEIT Desktop app through and are looking into it.

Already logged-in users should not be affected. Play is operational.

Sat, Apr 6, 2024, 06:56 PM