EU Matchmaking partial outage
Resolved
Degraded performance
Lasted for 52m

All issues resolved, you can go back to playing!

Tue, Apr 2, 2024, 05:13 PM
1 month ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Tue, Apr 2, 2024, 05:13 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Tue, Apr 2, 2024, 05:10 PM
49m earlier...

Identified

We have identified the issues and are working on a fix.

Tue, Apr 2, 2024, 04:20 PM