Sitewide loading issues
Resolved·Full outage

All issues resolved, you can go back to playing!

Mon, Apr 1, 2024, 12:25 AM
(1 year ago)
·
Affected components
Play
Login
Updates

Resolved

All issues resolved, you can go back to playing!

Mon, Apr 1, 2024, 12:25 AM

Monitoring

The queues have been reopened for all regions.

We will continue monitoring the situation as it settles.

Sun, Mar 31, 2024, 11:50 PM(35 minutes earlier)

Monitoring

We have rolled out a fix and are monitoring the situation.

We are gradually reopening the queues, starting with SA, NA, SEA, OCE.

Once confirmed all is well, we will reopen EU queues.

Sun, Mar 31, 2024, 11:43 PM

Investigating

We are aware of issues with the platform loading for users.

Sun, Mar 31, 2024, 10:28 PM(1 hour earlier)