CS2 EU Matchmaking Issues
Resolved
Partial outage
Lasted for 23m

All queue-related issues have been resolved and the queues have been reopened. You can go back to playing!

Thu, Mar 14, 2024, 09:25 PM
2 months ago
Affected components
Play
Updates

Resolved

All queue-related issues have been resolved and the queues have been reopened. You can go back to playing!

Thu, Mar 14, 2024, 09:25 PM
23m earlier...

Monitoring

We are aware of issues with the Counter-Strike 2 EU matchmaking queue.

The queue may be closed/reopened within the duration of this incident.

We have rolled out a fix for it and are monitoring the situation.

Thu, Mar 14, 2024, 09:01 PM