CS2 EU Matchmaking Issues
Resolved
Partial outage
Lasted for 20m

All issues resolved, you can go back to playing!

Mon, Mar 4, 2024, 06:04 PM
2 months ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Mon, Mar 4, 2024, 06:04 PM
20m earlier...

Investigating

We are aware of issues with the Counter-Strike 2 EU matchmaking queue and are looking into it.

Mon, Mar 4, 2024, 05:43 PM