CS2 EU Matchmaking Issues
Resolved·Partial outage

All issues resolved, you can go back to playing!

Thu, Feb 29, 2024, 09:15 PM
(1 year ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Feb 29, 2024, 09:15 PM

Monitoring

All of our services have recovered and are now fully operational. We will continue monitoring for any futher issues.

The affected queues (EU) have been reopened. You can now go back to playing!

Thu, Feb 29, 2024, 08:25 PM(49 minutes earlier)

Investigating

We are aware of issues with the Counter-Strike 2 EU matchmaking queue and are looking into it.

Thu, Feb 29, 2024, 07:45 PM(39 minutes earlier)