CS2 Match Creation Issues
Resolved
Full outage
Lasted for 2h

All issues resolved, you can go back to playing!

Thu, Feb 29, 2024, 12:30 AM
2 months ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Feb 29, 2024, 12:30 AM
14m earlier...

Monitoring

We have rolled out a fix and are monitoring the situation.

Thu, Feb 29, 2024, 12:15 AM
1h earlier...

Investigating

We've spotted something has gone wrong with matches not being created after the most recent Counter-Strike 2 game update, our teams are investigating the case.

We have closed all CS2 queues until the issue has been resolved.

Wed, Feb 28, 2024, 10:30 PM