CS2 EU Matchmaking Issues
Resolved
Partial outage
Lasted for 1h

All issues resolved. You can go back to playing!

Tue, Feb 20, 2024, 08:32 PM
3 months ago
Affected components
Play
Updates

Resolved

All issues resolved. You can go back to playing!

Tue, Feb 20, 2024, 08:32 PM
47m earlier...

Monitoring

All of our services have recovered and are now fully operational. We will continue monitoring for any futher issues.

All queues have been reopened. You can now go back to playing!

Tue, Feb 20, 2024, 07:45 PM
20m earlier...

Investigating

We are aware of issues with the Counter-Strike 2 EU matchmaking queue and are looking into it.

Tue, Feb 20, 2024, 07:24 PM