CS2 Matchmaking Service Instability
Resolved
Full outage
Lasted for 1h

All issues resolved, you can go back to playing!

Sun, Jan 28, 2024, 07:58 PM
3 months ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Sun, Jan 28, 2024, 07:58 PM
33m earlier...

Monitoring

All of the affected services have recovered and are operational. We will continue monitoring the case before closing the incident page.

Next status update within the next upcoming hour.

Sun, Jan 28, 2024, 07:24 PM
22m earlier...

Monitoring

Our CS2 matchmaking services have recovered and we are monitoring the queues as they have been reopened.

We've released a fix and will keep monitoring the queues' availability.

Sun, Jan 28, 2024, 07:01 PM
32m earlier...

Identified

We have closed all CS2 queues as we look deeper into the issue. We have also identified the issues and are working on a fix to deploy.

Sun, Jan 28, 2024, 06:28 PM
13m earlier...

Investigating

CS2 Matchmaking: We are working on resolving an issue with our matchmaking service.

Thanks for your patience.

Sun, Jan 28, 2024, 06:15 PM