Website loading issues
Resolved·Full outage

All issues resolved, you can go back to playing!

Mon, Jan 22, 2024, 07:18 PM
(1 year ago)
·
Affected components
Play
Login
Updates

Resolved

All issues resolved, you can go back to playing!

Mon, Jan 22, 2024, 07:18 PM

Investigating

The platform is now operational again and the queues have been reopened after a successful recovery of the services. Matches are successfully being created from now on.

Our development team is still monitoring the Matchmaking queues as they recover.

There are still slight issues with login, we are working on identifying the issue, as well as the fix.

Mon, Jan 22, 2024, 06:56 PM(22 minutes earlier)

Investigating

We are aware of ongoing issues with the platform and are looking into it.

Mon, Jan 22, 2024, 06:24 PM(31 minutes earlier)