Counter-Strike 2 FACEIT Matchmaking - Some matches not being finished as expected
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Wed, Dec 20, 2023, 11:50 AM
(1 year ago)
·
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Wed, Dec 20, 2023, 11:50 AM

Monitoring

We have just reverted a change affecting matches starting at 19:28 UTC+0, December 19th.

Matches should now be properly resulted and, therefore, operational as expected. Our teams are monitoring the situation as it quiets down.

Wed, Dec 20, 2023, 08:27 AM(3 hours earlier)

Investigating

We are aware of issues with some CS2 matchmaking matches ending on a TIE which should not be the case.

Our teams are aware of the issue and are coordinating a fix for it.

Wed, Dec 20, 2023, 07:06 AM(1 hour earlier)