Third Party Upper-End Issues
Resolved·Full outage

All issues resolved, you can go back to playing!

Thu, Nov 30, 2023, 02:53 AM
(1 year ago)
·
Affected components
Play
Login
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Thu, Nov 30, 2023, 02:53 AM

Monitoring

We have identified the issue, and it has been reported that the case has been resolved.

Our systems are coming back up online and recovering, we will continue to monitor its recovery process.

Thu, Nov 30, 2023, 02:24 AM(28 minutes earlier)

Investigating

We've spotted and issue preventing users from logging onto the FACEIT website and are currently investigating the case.

Thu, Nov 30, 2023, 02:04 AM(20 minutes earlier)