CS2 Match Creation Issues
Resolved·Full outage

All systems have returned to normal levels and are operational.

Thanks for the patience, you can go back to playing!

Fri, Nov 17, 2023, 04:29 AM
(1 year ago)
·
Affected components
Play
Updates

Resolved

All systems have returned to normal levels and are operational.

Thanks for the patience, you can go back to playing!

Fri, Nov 17, 2023, 04:29 AM

Monitoring

We've deployed the fix, CS2 Gameservers should be rolling out with the latest updates now.

We have reopened all queues and will monitor the situation as it should quiet down from now on. The game was updated three times tonight, please ensure you have the latest version downloaded before playing on the platform.

Thank you for your patience!

Fri, Nov 17, 2023, 03:26 AM(1 hour earlier)

Monitoring

A new CS2 game patch was released. We've closed the queues while we work on adjusting the fix and testing it before reopening the queues again.

We will provide an update within the next hour.

Fri, Nov 17, 2023, 03:01 AM(25 minutes earlier)

Monitoring

We've applied a fix for the CS2 Gameservers. We will begin testing the match creation on South America region and continue to monitor the situation.
If all follows smoothly, we will reopen the rest of the queues step-by-step.

Fri, Nov 17, 2023, 02:40 AM(20 minutes earlier)

Identified

We have identified the issue affecting Gameserver updates and are working on a fix.

We will provide an update within the next hour.

Fri, Nov 17, 2023, 02:10 AM(29 minutes earlier)

Investigating

We've spotted something has gone wrong with matches not being created after the most recent CS2 game update, our teams are investigating the case.

Fri, Nov 17, 2023, 01:19 AM(50 minutes earlier)