CS2 Update
Resolved
Degraded performance
Lasted for 3h

All servers updated and aborted percentages are normal.

Thu, Oct 26, 2023, 01:14 AM
6 months ago
Affected components
Play
Updates

Resolved

All servers updated and aborted percentages are normal.

Thu, Oct 26, 2023, 01:14 AM

Monitoring

All servers are updated and aborted percentages are back to normal.

Thu, Oct 26, 2023, 01:12 AM
3h earlier...

Monitoring

Servers are updated and queues are open

Wed, Oct 25, 2023, 09:57 PM
15m earlier...

Identified

We have closed the queues to let the servers update. Please update your game.

Wed, Oct 25, 2023, 09:42 PM