Matchmaking - Delayed match creation
Resolved
Partial outage
Lasted for 30m
Sun, Oct 15, 2023, 05:50 PM
7 months ago
Affected components
Play
Updates

Resolved

Issues fixed, you can go back to playing!

Sun, Oct 15, 2023, 05:50 PM
19m earlier...

Monitoring

Sun, Oct 15, 2023, 05:30 PM
10m earlier...

Investigating

We are having issues with Play.

Sun, Oct 15, 2023, 05:19 PM