Issues in Play flow
Resolved
Partial outage
Lasted for 47m
Tue, Oct 3, 2023, 11:47 AM
7 months ago
Affected components
Play
Updates

Resolved

Issues fixed, you can go back to playing!

Tue, Oct 3, 2023, 11:47 AM

Resolved

Issues fixed, you can go back to playing!

Tue, Oct 3, 2023, 11:47 AM
46m earlier...

Investigating

We are having issues with Play.

Tue, Oct 3, 2023, 11:00 AM