Increase in Matchmaking Queue Times
Resolved
Partial outage
Lasted for 1h

The issues have been resolved.

Fri, Sep 29, 2023, 11:20 PM
7 months ago
Affected components
Play
Updates

Resolved

The issues have been resolved.

Fri, Sep 29, 2023, 11:20 PM
55m earlier...

Monitoring

The Matchmaking service has recovered and is creating matches again. Our teams are monitoring the situation.

Fri, Sep 29, 2023, 10:24 PM

Investigating

We are having issues with Play.

Fri, Sep 29, 2023, 10:15 PM