Upper End Service Issues
Resolved·Full outage

This incident has been resolved.

Sat, Jul 15, 2023, 11:09 AM
(1 year ago)
·
Affected components
Play
Login
Subscriptions
Anti Cheat
Updates

Resolved

This incident has been resolved.

Sat, Jul 15, 2023, 11:09 AM

Monitoring

We are continuing to monitor for any further issues.

Sat, Jul 15, 2023, 04:52 AM(6 hours earlier)

Monitoring

We have applied a fix, and are monitoring for a resolution.

Sat, Jul 15, 2023, 04:20 AM(32 minutes earlier)

Investigating

We've spotted that something has gone very wrong. We're currently investigating the issue, and will provide an update soon.

Sat, Jul 15, 2023, 01:27 AM(2 hours earlier)