Anti-Cheat: Connectivity Issues
Resolved
Full outage
Lasted for 1h

This incident has been resolved.

Thu, Jun 1, 2023, 03:06 PM
11 months ago
Affected components
Anti Cheat
Updates

Resolved

This incident has been resolved.

Thu, Jun 1, 2023, 03:06 PM
44m earlier...

Monitoring

We have now opened the queues for CSGO and are monitoring the situation for anymore problems.

Thu, Jun 1, 2023, 02:21 PM
53m earlier...

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Thu, Jun 1, 2023, 01:28 PM