CSGO Free Queue Matching Issues
Affected components

No components marked as affected

Updates

Write-up published

Read it here

Resolved

During a surge following Steam downtime, many matches were incorrectly aborted shortly after creation. The issue was resolved and the system returned to normal activity at 19:15.

Thu, Jan 30, 2020, 10:26 PM
3h earlier...

Resolved

Queue numbers increased upon opening, after Steam issues resolved to over 8k during a 45 minute span.

Thu, Jan 30, 2020, 06:30 PM