CSGO - Delayed server configurations
Resolved
Degraded performance
Lasted for 1h

This incident has been resolved.

Sat, Mar 28, 2020, 05:26 PM
4 years ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Sat, Mar 28, 2020, 05:26 PM
53m earlier...

Monitoring

Situation is now improving but we are continuing to monitor

Sat, Mar 28, 2020, 04:33 PM

Identified

A fix has been implemented we are waiting for the change to be rolled out

Sat, Mar 28, 2020, 04:25 PM
34m earlier...

Investigating

We are investigating issues which might delay match configurations

Sat, Mar 28, 2020, 03:50 PM