CSGO Matchmaking issues.
Resolved
Partial outage
Lasted for 1h

The incident has been resolved and steam has stabilized, all queues are now open.

Mon, May 25, 2020, 09:29 PM
4 years ago
Affected components
Play
Updates

Resolved

The incident has been resolved and steam has stabilized, all queues are now open.

Mon, May 25, 2020, 09:29 PM
29m earlier...

Monitoring

Steam is still continuing to be very unstable for logins. Queues will be opened once stability is maintained. https://steamstat.us/

Mon, May 25, 2020, 08:59 PM
34m earlier...

Monitoring

Issue seems fully resolved from our side, waiting for steam to become stable aswell

Mon, May 25, 2020, 08:25 PM
14m earlier...

Identified

The issue has been identified and we are deploying a fix.

Mon, May 25, 2020, 08:11 PM
19m earlier...

Investigating

We are continuing to investigate this issue.

Mon, May 25, 2020, 07:51 PM
21m earlier...

Investigating

We are aware of issues with matches being slow to configure in some locations.

Mon, May 25, 2020, 07:30 PM