Desktop Client Captcha failures
Resolved
Degraded performance
Lasted for 2h

This incident has been resolved.

Tue, Jun 23, 2020, 07:45 PM
3 years ago
Affected components
Login
Updates

Resolved

This incident has been resolved.

Tue, Jun 23, 2020, 07:45 PM
2h earlier...

Investigating

We are continuing to investigate this issue.

Tue, Jun 23, 2020, 05:37 PM

Investigating

We are aware of an issue preventing users from logging into the desktop client. Current workaround would be to use the www.faceit.com to login to your account and play.

Tue, Jun 23, 2020, 05:33 PM