Steam Issues
Resolved
Partial outage
Lasted for 31m

This incident has been resolved.

Thu, Jan 21, 2021, 02:44 PM
3 years ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Thu, Jan 21, 2021, 02:44 PM
13m earlier...

Monitoring

Steam seems to have fixed issue - opening the queues.

Thu, Jan 21, 2021, 02:31 PM
17m earlier...

Investigating

Steam Down - Queues are currently closed due to a Steam outage and will be active again as soon as it's back up and running

Thu, Jan 21, 2021, 02:14 PM

Investigating

We are currently investigating this issue.

Thu, Jan 21, 2021, 02:12 PM