CSGO Free Europe Queue Matching Issues
Resolved·Degraded performance

This incident has been resolved.

Mon, Mar 22, 2021, 04:42 PM
(4 years ago)
·
Affected components
Play
Updates

Resolved

This incident has been resolved.

Mon, Mar 22, 2021, 04:42 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Mon, Mar 22, 2021, 04:14 PM(28 minutes earlier)

Identified

The issue has been identified and a fix is being implemented.

Mon, Mar 22, 2021, 04:10 PM

Investigating

We are currently investigating this issue.

Mon, Mar 22, 2021, 04:06 PM