CSGO Free Queue Matching Issues
Resolved
Degraded performance
Lasted for 1h

This incident has been resolved.

Mon, Mar 22, 2021, 08:11 PM
3 years ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Mon, Mar 22, 2021, 08:11 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Mon, Mar 22, 2021, 08:09 PM

Identified

The issue has been identified and a fix is being implemented.

Mon, Mar 22, 2021, 08:07 PM
1h earlier...

Investigating

We are currently investigating this issue.

Mon, Mar 22, 2021, 07:00 PM