CSGO Free Queue Matching Issues
Resolved
Degraded performance
Lasted for 1h

This incident has been resolved.

Tue, Mar 23, 2021, 08:34 PM
3 years ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Tue, Mar 23, 2021, 08:34 PM
14m earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Tue, Mar 23, 2021, 08:20 PM
1h earlier...

Investigating

We are currently investigating this issue.

Tue, Mar 23, 2021, 07:15 PM