Steam Issues
Resolved
Partial outage
Lasted for 5h

All queues are open and steam is stable.

Wed, Apr 7, 2021, 08:01 PM
3 years ago
Affected components
Play
Updates

Resolved

All queues are open and steam is stable.

Wed, Apr 7, 2021, 08:01 PM
1h earlier...

Monitoring

Steam has stabilized we are opening the queues and monitoring.

Wed, Apr 7, 2021, 06:45 PM
1h earlier...

Monitoring

Steam has shown signs of instability again. Queues have been closed.

Wed, Apr 7, 2021, 05:14 PM
42m earlier...

Monitoring

CSGO queues open

Wed, Apr 7, 2021, 04:31 PM
1h earlier...

Identified

CSGO queues closed

Wed, Apr 7, 2021, 03:02 PM

Investigating

CSGO queues closed

Wed, Apr 7, 2021, 02:53 PM