CSGO Server Update Issues
Resolved
Full outage
Lasted for 4h

This incident has been resolved.

Sat, Oct 22, 2022, 03:32 AM
1 year ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Sat, Oct 22, 2022, 03:32 AM
1h earlier...

Monitoring

We are continuing to monitor for further issues. SA is fully up now, NA has only Dallas, Denver, Chicago Locations, EU has only DE, NL and FR locations. SEA and OCE regions are still being worked on but should be up soon. Ty for you patience.

Sat, Oct 22, 2022, 02:11 AM
24m earlier...

Monitoring

A fix has been implemented and we are continuing to monitor the results. We are slowly bringing up each location and region one at a time. Once the issue is fully resolved all locations will be available.

Sat, Oct 22, 2022, 01:46 AM
12m earlier...

Identified

We are continuing to work on a fix for this issue.

Sat, Oct 22, 2022, 01:33 AM
1h earlier...

Identified

The issue has been identified and a fix is being implemented.

Fri, Oct 21, 2022, 11:56 PM
53m earlier...

Investigating

We are currently investigating this issue.

Fri, Oct 21, 2022, 11:02 PM