Resolved
All queues reopened; All issues resolved, you can go back to playing!
Monitoring
Most issues have been resolved.
We have reopened the queues for most regions, and look forward to open EU queues soon.
Thank you for your patience!
Investigating
We are aware of ongoing platform and anti-cheat issues, and queues have been temporarily closed while we work to resolve them.