Resolved
All issues resolved, you can go back to playing!
Monitoring
We have rolled out a fix and are monitoring the situation. All CS2 queues have been reopened.
Identified
We have identified the issues and are working on the fixes.
Investigating
We are aware of issues with players being unable to connect to the game servers after the most recent CS2 game update.
All CS2 queues have been closed while we investigate the issue.