FACEIT

Powered by
Privacy policy

·

Terms of service
Platform Outage
Resolved·Full outage

All issues resolved, you can go back to playing!

Sun, Jul 12, 2026, 02:45 PM
(2 months ago)
·
Affected components
Jul 12, 2026, 02:22 PM
02:45 PM
Play
Login
Anti Cheat
Updates

Resolved

All issues resolved, you can go back to playing!

Sun, Jul 12, 2026, 02:45 PM

Monitoring

We have rolled out a fix and are monitoring the situation.

Sun, Jul 12, 2026, 02:35 PM

Investigating

We are aware of an issue with the Anti-cheat disconnecting players from matches, and generic issues reported with the platform. We are investigating and working on a fix.

Sun, Jul 12, 2026, 02:22 PM(13 minutes earlier)