FACEIT

Powered by
Privacy policy

·

Terms of service
Slow matching
Resolved·Degraded performance

All issues resolved, you can go back to playing!

Fri, Apr 24, 2026, 08:28 PM
(1 month ago)
·
Affected components
Apr 24, 2026, 08:18 PM
08:28 PM
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Apr 24, 2026, 08:28 PM

Investigating

We are aware of issues with the platform. We might temporarily close queues for new joins while working through the issue.

Fri, Apr 24, 2026, 08:18 PM(10 minutes earlier)