Resolved
All service issues have been resolved, you can go back to playing!
Investigating
We've temporarily closed the queues due to a service issue.
Investigating
We're aware of matches that don't start or end properly. We've released a fix and are monitoring as the services recover.