EU Matchmaking is currently experiencing issues and may be intermittently unavailable. Our team is working to resolve this as quickly as possible
Resolved
Degraded performance
Lasted for 1h

All issues resolved, you can go back to playing!

Fri, Apr 5, 2024, 09:14 PM
1 month ago
Affected components
Play
Updates

Resolved

All issues resolved, you can go back to playing!

Fri, Apr 5, 2024, 09:14 PM
1h earlier...

Identified

We have identified the issues and are working on a fix.

Fri, Apr 5, 2024, 08:02 PM