CSGO Europe - Germany Server Instability
Affected components

No components marked as affected

Updates

Write-up published

Read it here

Resolved

A portion of servers within the Germany Data-center encountered a ISP Loss and a very large percentage of players were disconnected from servers. Data-center issues were mitigated approximately five minutes later.

Thu, Jan 30, 2020, 11:54 PM
21h earlier...

Resolved

Some Germany servers became unstable and the majority of players were removed from live matches.

Thu, Jan 30, 2020, 02:30 AM