Affected components

No components marked as affected

Updates

Write-up published

Read it here

Resolved

All newly created matches that were not ongoing were cancelled, queues were opened again in CSGO once stability had been restored.

This occurred three times over a 60 minute span this evening. Once stable again the queues were reopened.

Wed, Feb 5, 2020, 12:02 AM
1h earlier...

Resolved

Queues will reopen once stability is restored - https://steamstat.us/

Tue, Feb 4, 2020, 11:00 PM