Issues Accessing Site
Resolved
Partial outage
Lasted for 2h

This incident has been resolved.

Fri, Feb 28, 2020, 05:55 PM
4 years ago
Affected components
Login
Updates

Resolved

This incident has been resolved.

Fri, Feb 28, 2020, 05:55 PM
56m earlier...

Identified

The issue has been identified and resolved for users on browser. FACEIT client issues still persisting for some users.

Fri, Feb 28, 2020, 04:59 PM
50m earlier...

Investigating

We are continuing to investigate this issue.

Fri, Feb 28, 2020, 04:08 PM
18m earlier...

Investigating

We’ve received reports of user getting the blank page of cloudflare “You’ve been blocked” - we are investigating

Fri, Feb 28, 2020, 03:50 PM