CSGO - Match Configuring Issues
Resolved
Degraded performance
Lasted for 42m

This incident has been resolved.

Wed, Nov 18, 2020, 08:07 PM
3 years ago
Affected components
Play
Updates

Resolved

This incident has been resolved.

Wed, Nov 18, 2020, 08:07 PM
33m earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Wed, Nov 18, 2020, 07:33 PM

Investigating

We are currently investigating this issue.

Wed, Nov 18, 2020, 07:24 PM